Announcement

Collapse
No announcement yet.

True TDD-1 problem. Help!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • KillianBoy
    replied
    capesalyers,
    I assume you mean a plug-in type ETC, wired-in will require expert skills to run in a True as Iceman pointed out, all my comments regarding ETC is basically to save the keg and compressor and not meant to be a long term solution (hence "band-aid").
    I think we are all in agreement, call a tech, he will get unit running the way it is supposed to.
    Sensor should be placed middle of unit hanging, set point should be 34-38 degrees (depending on if cut-in or cut-out), if you place in glass of water, set point should be 38 degrees and differential should be 1-2 degrees.
    KB
    Last edited by KillianBoy; 04-04-2013, 05:13 PM.

    Leave a comment:


  • THE ICEMAN
    replied
    Originally posted by capesalyers View Post
    Thanks for the reply. I will look into getting a tech out to look at it. Also, if I went with the "band-aid" from what I can tell the unit would plug into the controller and it would turn on/off at the desired temp. There is an evap fan that runs constantly, how would this effect the overall unit because the evap fan would be turning off too? Also would I install the temp probe on the evap, like the original thermostat or just inside the unit?

    Again, thanks for the help!

    --Shawn
    As to the external controller... Not the best choice for that type of unit. You are correct in your concerns about the evaporator fan. The fan should run all the time for the unit to work properly. Although it can be done, it would take quite a bit of re-wiring to get an external controller to work. Stay away from it.

    As to your initial post... Where do you have the unit located? Does it have enough room to breathe? Is the condenser coil down at the compressor clean all the way through & is the condenser fan running when the compressor is running? Also, how does the door seal look? Is it sealing properly? One way to test the seal is to take a dollar bill & while holding it, close the door on it at various points around the door. If you feel resistance while pulling the dollar out, the seal should be fine. If the dollar slides out without much resistance at all you may have seal issues.


    ​THE ICEMAN
    Last edited by THE ICEMAN; 04-04-2013, 02:44 PM. Reason: Added goodness

    Leave a comment:


  • capesalyers
    replied
    Thanks for the reply. I will look into getting a tech out to look at it. Also, if I went with the "band-aid" from what I can tell the unit would plug into the controller and it would turn on/off at the desired temp. There is an evap fan that runs constantly, how would this effect the overall unit because the evap fan would be turning off too? Also would I install the temp probe on the evap, like the original thermostat or just inside the unit?

    Again, thanks for the help!

    --Shawn

    Leave a comment:


  • KillianBoy
    replied
    Shawn,
    Welcome, I've been waiting for the refrigeration pros to run you an answer, I think I'll throw my 2 cents worth.
    There are a myriad of things that can cause the compressor to run non-stop, I'd call a tech and live with the price, you will still have to service unit every 18-24 months anyway.
    If you are certain 100% compressor/refrigeration unit works and it is just not turning off, a band-aid solution would be to buy a external temperature controller, hook up and you are good.
    I'd call a tech, he can clear the unit to work properly for the remainder of its life.
    KB
    Last edited by KillianBoy; 04-04-2013, 03:47 AM.

    Leave a comment:


  • capesalyers
    started a topic True TDD-1 problem. Help!!!

    True TDD-1 problem. Help!!!

    I purchased a True TDD-1 on Craigslist a few months ago and I have to say I got an awesome deal on it ($175). When I went to look at it, it worked fine and I heard the compressor cycle. After getting it home and letting it settle I noticed the compressor wouldn't cycle so I ordered a thermostat and replaced it. Everything was fine until yesterday, it's not cycling AGAIN! My beer line is freezing and I'm concerned about damaging the compressor. Any help, thoughts or advice would be greatly appreciated.

    I have searched the site and did not find anything so I apologize if this has been asked/answered before.

    Also props to Micro Matic for giving us this community.

    Thanks,

    Shawn
Working...
X